Advertise Here
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Inebriated Staff Ninja DrunkPunk's Avatar
    Join Date
    Mar 2013

    Quote Originally Posted by wienersoup View Post
    I installed it. It works fine. I was able to download my purchased copy of kotor and that also worked. I did however need to use a mouse to properly navigate and access menus that hide to the side. Much like es file explorer.

    Sent from my SM-G900V using Tapatalk
    Funny, I kept getting an error when trying to install it. Link to the APK you used please?
    DrnkPnk says, "Obey The Beard!"
    I helped create a mini-game in Explosive Dinosaurs. Otakupunk played it, and now you can too!

    Follow my weirdness - > Instagram

  2. #12

    My experience with sideloading Amazon app store has been hit and miss. I was able to get a few games to download, install and play (Final Fantasy 4 and Doom and Destiny Advance). However, it now seems to refuse to start/crash to "desktop" (kinda hard to tell which) without an error code everytime I try to launch it now. Reinstalling the app and/or clearing the cache fixes the problem temporarily but eventually crashes again and again. Rinse and repeat. Very frustrating to say the least. I've lost count how many times I've tried to get KOTOR to download the install files. Always seems to download everything fine and then fail the file verification process. In fact, my whole experience with the Forge so far has been like this. I tried to launch Cortex the other day and it failed to launch after it downloaded a few files and told me to try again in a few minutes. After half a dozen tries and system restarts I finally gave up and unplugged the damn thing. Factory reset solves all issues for a while but they eventually return. My Forge TV is currently collecting dust until Razer decides to release the long overdue Marshmellow update.

  3. #13
    OUYAForum Fan xanderten50's Avatar
    Join Date
    May 2013

    Minor bump to this since I have since got my own Forge and was able to test it myself...
    Netflix and Amazon instant don't even show up in the app no matter what I do, and if I install the Amazon instant apk from my phone it installs fine but refuses to play anything... boo
    Hmmm... good signatures are hard to come by...

  4. #14
    OUYAForum Fan knave's Avatar
    Join Date
    Jul 2013

    I didn't easily find an APK for the Amazon Appstore, so I installes Amazon Underground. The UI sucks, but I was able to install Apps. KOTOR works beautifully. Shadowblade does not. (but the Humble Bundle version does!)


  • Submit to Digg Digg
  • Submit to
  • Submit to StumbleUpon StumbleUpon
  • Submit to Google Google

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts