View Full Version : Recover potentially bricked device?

12-21-2013, 02:22 PM
Hi, I hope this is the right place to ask this...

So a couple of days ago I installed CWM and CM10 from XDA. Now the device won't boot(it gets stuck in boot animation), the reason is that I can't flash the boot.img because I can't get ADB to work and therefore not able to boot into fastboot to flash the kernel/boot.img. I can get to CWM by hitting SysRq/Alt/I a couple of times but that's a little help since CWM doesn't provide any help without adb. I tried everything, I've been googling for hours and still no luck. I have reinstalled ADB and OUYA usb drivers like 10 times but adb doesn't simply recognize the device while it's in CWM(where ADB should be enabled). If only I could boot to stock recovery but I don't think that's ever gonna happen. Also I don't have stock rom zip in my int. storage and can't push anything there because I'd need ADB for that...

Is there anything I could try? I only need a way to get adb to work or push one file in the storage(since apparentally usb memory is not supported in recovery)...


12-21-2013, 06:41 PM
as long as you are able to boot to cwm chances are good you will recover.
Try a different cable/port/computer and try to figure our why you are not able to connect via adb.
Did you set up everything correctly?
Just stick to this guide and try adb again:

1. Install the Android SDK (http://developer.android.com/sdk/index.html)

2. Open SDK Manager and install the following packages:
- Tools: Including both Android SDK and Android SDK
- Android 4.1 (API 16): SDK Platform
- Android 4.0 (API 14): SDK Platform
- Extras: Android Support Library, Google USB Driver

3. Navigate to /android-sdk/extras/google/usb_driver

4. Open android_winusb.inf in an editor (I use Notepad++)

5. Add the following lines beneath [Google.NTx86]:

;OUYA Console
%SingleAdbInterface% = USB_Install, USB\VID_2836&PID_0010
%CompositeAdbInterface% = USB_Install, USB\VID_2836&PID_0010&MI_01

6. Connect your Ouya via micro USB to your computer and turn it on (it needs to be on for adb to work)

7. Open a command window in /android-sdk/platform-tools and run the following commands:

adb kill-server
echo 0x2836 >> "%USERPROFILE%\.android\adb_usb.ini"
adb start-server
adb devices

8. After 'adb devices' you should see a number, which signifies your connected console

9. You should now be ready to use adb

12-21-2013, 06:44 PM
There are two programs I use for bricked Samsung devices called Odin 3.09, and heimdall-suite-1.3.2. You could take a look at those, not sure if they work for anything other than samsungs. I have never tried to flash an OUYA yet, and I probably wont because the are strictly dev consols for me.

12-23-2013, 11:30 AM
Sorry to say but they will be useless for ouya. Our tools are simple adb and fastboot. That's it.
Any news? My bet is you missed out step 7. What version of windows are you using anyway? Many people are reporting problems when it comes to win8 + adb.

Gesendet von meinem HTC One X+ mit Tapatalk

12-23-2013, 07:25 PM
I figured as much, just though I would mention it.

Step 5 and 7 are probably the key if you can't get it connected, I am Consonantly switching between 5 android devices on my computer, and some times its a real argument to get ADB to recognize a device, especially when swapping between 2 OUYAs.

You could try looking at the following it seams to be a GUI interface that uses fastboot an ADB

edit: Try a cycling usb ports