View Full Version : Optware

10-15-2013, 02:49 PM
I would nolonger recommend running opt-ware under stock Ouya
I have no idea if my kernel is still a safe choice, I no don't use it anymore.

Milaq's CM11 is a much better choice (http://forum.xda-developers.com/showthread.php?t=2692843).

The performance is better and the kernel has CFQ has as an option already.

Still running NZNGET, Transmission, sickbeard, couch potato and a megamek server as well as Kodi, netflix, google music, youtube etc

Assuming you utilize scheduling and ionice it all plays together very well
__________________________________________________ __________________________________________________ __________________
Anyone else using optware?

I installed using the script Here (http://sourceforge.net/p/optware-android/wiki/Home/) only change I made to the script was switching to unstable repo.

Everything installed fine, aside from a bit of struggle getting ssh keys setup* everything works well.

Only issue I'm having is getting the init scrips to run at boot. I'm running the latest stockplus rom and have put the scripts (just S40sshd and the optware init script until i get it working) in /etc/init.d

It works great if i manually run them in order after boot.

So for Ive tried just putting them in init.d, running Universal Init.d (https://play.google.com/store/apps/details?id=com.androguide.universal.init.d) and running Smanager (https://play.google.com/store/apps/details?id=os.tools.scriptmanager&hl=en), which FC's before I can do anything.

*you need to put authorized_keys in /opt/home/root/.shh, and properly chmod (600 for authorized_key, and 700 forr root/ and .ssh/) "/opt/sbin/sshd -p 22 -D -d -e" is your friend. Once setup, a good /opt/home/root/.profile makes for a very usable little Linux box

Ok so i got SABnzbd(0.7.16) and Sickbeard(git) installed.

First d/l and I'm hitting 3.7MB/s! (That's 29.6 Mbps ona 30Mbps cable connection)
Basically it totally soaked the connection, that is far and away the best performance I've seen on a low power device.
for reference I've run it on a Wdtvlive(crap, >1MB/s), and a pogoplug running arch linux(decent could hit 2.2MB/s)

these instructions (http://www.linksysinfo.org/index.php?threads/setup-usenet-client-with-optware.37963/") pretty much work with a couple differences

You need to add an explicit nsswitch.conf, as android's routing is retarded. I used the one here (https://github.com/pfalcon/optware-android) if you don't localhost is unreachable, which will break all kinds of things.

I also installed util-linux-ng, which also provides ionice, and some other useful nix tools

SABnzbd didn't seem to like 8080 for some reason, i put it on and it's working fine.

Sickbeard's XBMC ingratiation works nicely, once sabnzbd is working you pretty much just have to dl and run sickbeard.

As an aside, I'm running optware on an external drive, with opt mount -o bind /data/opt | space constraints aside, if i move to CM, or need to recover I'd hate to loose the work. This way i just need to re add my mounts.

I've made some headway with the init scripts, universal init.d is starting optware initialization and sshd, I still need to manually run my piracy script.

If anyone better knows android init, I'd appreciate the help.

↓ Posts merged. Please do not double post. Try to use the 'Edit Post' button below next time to add to your previous post. Thanks. ↓

11-10-2013, 05:21 AM
I rooted my ouya with OuyaToolbox 1.1.2 and test versions.
And I got ADB access under Windows 7.
I tried manually setup steps that I found there (http://www.nslu2-linux.org/wiki/Optware/HomePage). Except one thing. The feed is "http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable". But Im always getting "read-only file system" message. Is there any mistake? What should I do?

I need optware, because I want to install transmission with these steps (http://www.reddit.com/r/ladfrombrad/comments/1ayvkx/a_torrent_server_ie_transmission_daemon_for_your/).


This time I tried these (http://www.xbmchub.com/forums/ouya-gaming-console/9970-%5Bhow-%5D-gain-root-access-superuser-permissions-ouya.html). And I rooted my ouya. First time, I couldn't root. Then I used optware-install-via-adb.sh (optware for android). But it didn't work. Link of "arm-2008q1-126-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2" is not working. Also the link is not working when I write it to an explorer (chrome). And I'm getting ready-only file system message only for this wget step.


The link worked. But I'm still getting problem.

12-02-2013, 12:56 AM
I did it from a Linux PC, the install script doesen't work in Windows. Try running it from a live cd.

The manual steps probably won't work in android, as google ripped out many standard nix tools.

Also optware moves slow, you probably want to go with unstable.

As an aside, i've had some issue with high disk IO freezing the system.

The only IO scheduler in Stock Plus seems to be noop, for our purposes cfq or similar would be much prefered.

12-02-2013, 01:00 PM
The highest dl speed I've had is 68mbps

Sent from my LGL55C using Tapatalk 2

12-03-2013, 02:35 AM
Here is a kernel(my first driod kernel:)); I compiled with cfq as IO scheduler and nfsv3/v4 client&server.

kernel (https://www.dropbox.com/s/fv3dfd82ag1p35s/kernelA1.img)

Should be better for mixed usage. Ionice will work now, with idle class the impact of DL'ing on the system usability should be minimal.

I would definitely install this (http://forum.xda-developers.com/showthread.php?t=2499673) if messing with kernels.

Anyone have init scripts working yet btw?

Edit 2/10/14: this is for stockplus. For stock look for the later post

12-03-2013, 02:37 AM
I have not edited any of my system. Not even rooted anymore.

Sent from my LGL55C using Tapatalk 2

12-04-2013, 06:18 PM
I have not edited any of my system. Not even rooted anymore.

Sent from my LGL55C using Tapatalk 2

Well then your missing out on most of what these little computers can do.

__________________________________________________ ________________________________________________

I've stressed tested the system and was unable to freeze it. XBMC stuttered a little but that was it. Ionicing it should fix even that.

Cfq made a huge improvement with no noticeable degradation, it should probably be the default as noop,while good for flash, is a poor choice for low bandwidth spinning disks.

I also switched to nzbget as V12 is feature complete to me, and uses 1/3 the resources of sabnzbd and added couchpotato and transmission.

Transmission had to be beaten into submission, If anyone wants the details just ask.

With the horsepower these things have they'd also make great asterix boxes, or LAMP for a personal website.
I'll probably install ownCloud (http://owncloud.org/) next, just for the hell of it really.

The fact that it runs emulators is just icing on the cake, I've been looking for a low watt all in one NAT, downloader and front end for a while. This is the first device to really handle it well.

If ouya 2 has usb3(ideally more then one) I''ll be one of the first to buy it.

12-13-2013, 08:25 PM
Thank you dougunder.
Someone told to me same thing and I already did.
Like you say, the system is always freezing. But these steps (http://forum.xda-developers.com/showthread.php?t=2499673) are difficult to understand with my english :). If I will just flash it with CWM Recovery like in there (http://forum.xda-developers.com/showthread.php?t=2295645), does it work?

12-18-2013, 02:33 PM
I haven't tried. The ouya can be bricked super easily. I would not flash the kernel. Let me see if i can succinctly restate the steps.

copy the downloaded boot image and recovery image to the OUYA's sdcard

adb push boot102513.img /sdcard/boot102513.img


adb push rcvy102513.img /sdcard/rcvy102513.img

If you setup ssh you can use scp instead, this is assuming you run *nix on your pc
scp $file [email protected]:/sdcard

cd /dev/block/platform/sdhci-tegra.3/by-name
cat LNX > /sdcard/kernel.img
If sshing as root, su not nessasary

md5sum /sdcard/boot102513.img
Do not proceed unless you get "e4b1b1ad553e55ad0b2ce3fb8f5bf623"

Flash with

dd if=/sdcard/boot102513.img of=LNX

For the Recovery image, verify by running:

md5sum /sdcard/rcvy102513.img
Do not proceed unless you get "dda0811a7e8e82a7d4ad3fa4c3ae35e4".

Again for the Recovery image option, flash to the Ouya by running:

dd if=/sdcard/rcvy102513.img of=SOS


Assuming this works, ssh/adb back in and

mv /sdcard/kernel.img /sdcard/kernelA1.img
exit back to your PC and

scp $mykernel [email protected]:/sdcard/kernel.img

connect back to ouya and verifiy things

cd /sdcard
ls (ensure kernel.img and kernelA1.img are there)

IF you do flash my kernel, please let me know how it works.

12-21-2013, 09:40 AM
Thank you again. I will try it when I have free time.

12-25-2013, 12:56 AM
i use optware for pyload and it's working like a charm, but one last thing i would need is autostart. any news for this?
no matter if init or script manager.

12-25-2013, 08:26 AM
Yes. If you look at bottom of this page (http://www.reddit.com/r/ladfrombrad/comments/1ayvkx/a_torrent_server_ie_transmission_daemon_for_your/), you can see. ladfrombrad suggested Rom Toolbox to me. Its working very well. There is the script that you need.

ls /opt >/dev/null 2>&1 || su -c /data/opt/optware-init.sh
export PATH=/opt/sbin:/opt/bin:/bin:/system/bin
if busybox test $(busybox id -u) = 0; then HOME=/opt/home/root; else HOME=/opt/home/user; fi
export HOME

There is a line which is typed "transmission-daemon". This line starts transmission daemon. Just edit it, type your command. Then, type this script to Rom Toolbox > scripter and set it "Set on boot".

Sorry for grammar mistakes. I hope you understand :).

12-25-2013, 09:33 AM
Nice. I think I missed that one. Thanks :-)

Gesendet von meinem HTC One X+ mit Tapatalk

01-09-2014, 07:50 PM

1) Have you managed to get ssh work? How? Openssh?
-What is root password?

1) Has someone managed to get samba working?
I know I can do it with android apps, but I rather use linux to keep it as light as possible.

01-09-2014, 08:33 PM
You are all beyond my simple user skills. So effectively a LINUX os running on the OUYA? That's terrific. Would be cool to see an OPENELEC compiled and working for OUYA.

01-10-2014, 04:48 PM
I came this step "md5sum /sdcard/rcvy102513.img". But I got this error; "sh: md5sum: not found".

01-15-2014, 06:09 PM
I have 2 problems:
- Installed samba 2.
- Can't get autostart working with it
- Can't get sickbeard download anything. It doesn't find episodes. Here is my tutorial for odroid u2, it probably works quite well also with ouya

01-25-2014, 04:17 PM
I think Optware is not good for transmission. This is my all problem.

Is there any way to install Openwrt, Entware or Openelec?

I found an explanation for other devices and I tried to install Entware but I couldn't. Now, I'm waiting for help.

02-04-2014, 03:56 PM
Hey Guys, sorry I've not been on the thread in a while.

Couple of things.

1. I have to set up a OUYA for a friend, I'll fully document the steps taken. I don't have ouya w/ me, so stuff below may not be 100% right
2. Ferhat.u, you don't have md5sum installed or it's not in your PATH.
3. PATH is super important, if SAB, SB etc will not run right if they cant find deps. Initscrips must contain EXPORT PATH=/opt/bin;/opt/xbin;$otherneeds
4. SSH works fine, you need the right keys installed. Read post one again, if you have issue adb in and run "/opt/sbin/sshd -p 22 -D -d -e" then try to "ssh [email protected]" from PC. It will tell you what went wrong.
5. Transmission works fine but is a pain to get installed. You need to generate the config then tell it where the config is. you also need to edit settings.json to allow your IP to connect. I will document w/ more detail.
6. I did end up getting Universal init.d working after switching off the non working system init'd support.

This ouya I'll be setting up with XPOSED Mod Collection on current stock running Eternity boot loader and kernel, which i will probably recompile for a lower clock and ensure it's using CFQ io scheduler and repack with stock initrd.
I will document here the steps needed to get optware running well.

Edit: 2/5/14
Ok, So I've rooted and installed the playstore and disabled auto updates with this (http://forum.xda-developers.com/showthread.php?t=2359390) app. Point and click, just got to install Xposed installer before it will work, which was easy to do but not abundantly clear that it was necessary.

I attempted to install optware , but discovered that it doesn't seem to work with ADB over the network. I'll try again tonight once i have a long enough micro usb cable.

Also, I'm running Debian Jessie on my PC, any commands etc given will be for the Bash shell and assumes you have an up to date GNU/Linux install.

Edit 2/6/14

Had a bit of time yesterday to work on this. The script works fine over ip adb, I had just forgotten to install busybox.
I installed optware using the optware-install-via-adb.sh script, only change i made was changing line 33 from




I then installed openssh and nano(not a vi fan...)

adb shell
ipkg update
ipkg install nano
ipkg install openssh

ssh-keygen creates /opt/home/root/.ssh and puts the required keys within. I left the password blank.

Leaving the adb shell connected, open a new terminal tab on your PC and.

adb push ~/.ssh/id_rsa.pub /opt/root/.ssh/authorized_keys

Back to the adb shell

chown root /opt/home/root/.ssh/authorized_keys
chmon 600 /opt/home/root/.ssh/authorized_keys
/opt/sbin/sshd -p 22 -D -d -e

That will open the ssh server in a verbose mode. go back to you local terminal tab and enter

ssh [email protected]

It should let you in, if not have a look at the adb tab. You will likely see a warning about Permissions/octel (you didn't chown chmod right) or authentication (something is amiss with your keys).

Just write you init script and your good. I'm not really happy with the universal init kludge, If you have a better idea please post.

Also, "ping ouya" works on my network, My router runs dd-wrt, i added a dhcp reservation with ouya as the label and my linux boxen all picked it up. The ouya it's self need an explicit /etc/hosts to connect by name for some reason.

This evening i plan to install the Eternity boot loader and reconfigure, recompile and repack the stock kernel. Had a look at the Eternity kernel git tree and the don't seem to be bringing anything to the table beyond OCing, which IMHO is a bad idea. If the mfg limited the speed it was for a reason. The ouya is at the edge of the thermal comfort zone without OCing. The Ouya kernel is pretty much vanilla Linux anyway.

Edit 2/7
Installed the boot loader following the instructions. Can boot stock kernel, so far nothing else. Tried a stock cfg + CFQ, eternity kernel and a stock config kernel, built with emdebian arm toolkit(gcc 4.7).
Sofar no dice, and w/o CFQ optware is fairly useless. May just flash to stockplus as i know my kernel runs under that. I guess I'll try pulling different git commits and maybe build with the official android toolkit, perhaps pull the config.gz from the OUYA instead of using tegra3_android_defconfig.

Pulled ouya running config and diff'd against tegra3_android_defconfig. Had to enable CONFIG_TRUSTED_FOUNDATIONS

So without further adieu here (https://www.dropbox.com/s/efw430n5nyqszhp/altboot.img.bz2) is working cfq boot image for current(2/07 hotfix) Ouya.

RIght now only change is cfq, Probably will change CPU governor from userspace to ondemand. Unsure about value of kernel NFS as nfs-utils are missing from optware. I'm going to try the user space NFS server, before attempting to port nfs-utils.

Also, I allowed OUYA to update (dd's back LNXBACKUP.img) that cleared out my optware install, when i adb'd in to reinstall the bootloader, i received the same md5sum error Ferhat.u got. Seems the busybox symlinks are incomplete so you need to run
busybox md5sum /sdcard/LNXBACKUP.img

Or fix the symlinks. Prob didn't notice before as a fleshed out optware likely provides the same tools.

It seems you need to both
fastboot flash altboot altboot.img
#as well as
adb push altboot.img /sdcard/altboot.img

In order for it to boot with the EP menu, flashboot boot works as expected.

Edit 2/10

optkernel.tar.bz2 (https://www.dropbox.com/s/genhq95n4myaryx/optkernel.tar.bz2)

A kernel that has cfq io scheduler and ondemand cpu governor. It now runs /data/opt/optware-init.sh and /opt/etc/init.d/* during boot. You need to put the optware-services.sh file in /data/opt for the init.d to run.

i use optware for pyload and it's working like a charm, but one last thing i would need is autostart. any news for this?
no matter if init or script manager.

Finally got this! I Built a modified boot.img that runs /data/opt/optware-init.sh then /opt/optinitd.sh which runs /opt/etc/init.d/*
The scripts in /opt/etc/init.d need to be clean for this to work (ie return no error message). I ended up taking the PID stuff out of S40sshd and sshd was enabled on boot.

At work now but I'll post the files this evening.

Also ended up having more problems with busybox. I have been using the jrummy installer, which froze when i tried to redo the symlinks.

I removed that and used the installer in the F-droid Repository (https://f-droid.org/‎)

It's playing nicely now

02-25-2014, 10:22 PM
How do you guys find the system performance with Transmission and Sickbeard runnin with XBMC i am worried about running everything at the same time whilst trying to play 1080p movies.

03-07-2014, 07:04 AM
Sorry guys, I do not use Ouya with transmission anymore. I was banned from BTN because of this issue. My bonus points increased rapidly. I couldnt understand how. But then staffs believed I cheated, and banned me.

11-25-2014, 11:27 PM
I found that transmission daemon installer, what you guys think?