View Full Version : Problem editing .apk for OUYA

04-17-2014, 05:08 PM
My apologies if there is already a topic on this.

After jumping back into Android I have run into a unique problem while customizing an apk for my OUYA. Here are the details:

My intention was to modify some icons of the old school game system apk's such as Nintendo, SNES, etc . I started with an NES emulator apk. Having been familiar with apk editing, I dissaembled the apk using apktool. The only edited file included the ouya_icon.png to change the app icon (image file format kept the same and exact dimensions). Upon reassembling the apk and signing (using original signature/keep folder method) the apk installs on the OUYA however it appears that certain menu formats are out of line and some missing all together (such as "Screen Area" option) I am wondering if something is getting lost in the assembly stage.

I tried simply unpacking then reassembling the apk with NO CHANGES made to the apk whatsoever and same result. The menu's are now misaligned and certain menu's are missing all together. I have tried using non-original signatuires, etc but all having the same result.

Has anyone had a smiliar problems editing OUYA apk's or know what the issue could be? Any help would be greatly appreciated!