Close
Advertise Here
Results 1 to 5 of 5
  1. #1


    Final Fantasy Legends Toki no Suisho - AKA Crystal of Space-Time

    Just wanted to inform everyone that yet another game works on ouya. Game in question is noted in the title for this thread. Final Fantasy Legends Toki no Suisho. A few things to note about this game once side loaded:

    1. It can be found on qooapp app store. Use chrome to find the site, and a version of it should be in english. From there the app to download this game can be found.

    2. The game once completely installed, and extra data downloaded is 208MB.

    3. Touch pad, or usb mouse only. Seems to have no function with any controllers.

    4. The game will look for Google play services, but they aren't needed. Can be played regardless.

    5. You may experience an initial crash after the game sets itself up and gets into the first battle sequence, however after re-entering the game this should cease. I played for a good 2 hours without it happening again.

    6. It's completely in japanese or whichever asian specific language it's in so getting a grasp on story is shot unless you have understanding of the language presented in it. However some things are completely navigable with a little trial and error. Pretty much enough to figure how to equip weapons, attack, and so forth.

    7. Seems a little pixely, but I believe it's just the games art style.

    Last thing I should note from my own stand point is that my ouya is rooted, so I got no idea how this will work on un-rooted consoles, though most apps I tried prior to re-rooting with king root worked, so give it a shot if you wish.

  2. #2
    OUYA Developer Nooskewl's Avatar
    Join Date
    Jul 2013
    Location
    Canmore, Alberta
    Posts
    714


    Is Qoo App a pirated games app or? Probably one of the ones that download my APKs from Google Play then cancel their order after they've copied it.

  3. #3


    If by pirated you mean it hosts already paid for apps then no it doesn't. The only things it hosts are APKs, and any extra one time data download that might not be obtainable elsewhere in the world due to having to connect to asian specific servers, and such. Some games show as google play downloads on it, and direct you to the appropriate google play page (so a spoofed vpn may be needed on those), but not all. They don't host any paid for content downloads, or anything like that. No modded games either. If extra data download for games that might need connecting to asian servers is pirating in your eyes then don't use the app. I personally haven't seen any game I downloaded come with any paid for content. Haven't had any problems with any games I've downloaded from it. Just have to keep up on the updates naturally. If by ordering stuff you mean IAPs, then I personally haven't tried those, since some of the games that look for a google play games account might not allow it, unless you went through the hassle of spoofing your vpn, and the criteria associated with that. Besides most of the games I've played I've never really seen any need for IAPs in them.

    Besides to me it's just quicker than trying to spoof a vpn, registering another google play account, and messing with my phone or console settings. Personally I got a few games on my phone with qooapp as well. Such as Rockman GoGo, Mobius Final Fantasy, Final Fantasy Brave Exvious, Final Fantasy Grand Masters (I really oughta try that since the battlefields are open, and you control your character via virtual analog stick), and I'm always trying others.
    Last edited by nightwishfan1; 06-13-2016 at 12:55 PM. Reason: not allow it

  4. #4
    OUYA Developer Nooskewl's Avatar
    Join Date
    Jul 2013
    Location
    Canmore, Alberta
    Posts
    714


    OK I shouldn't have assumed they were paid games or pirated.

  5. #5


    Qooapp is just a way to get past region restrictions that the various google play store fronts out there present when trying to get something that isn't in our region. Nothing more, nothing less. Also saves time from installing unnecessary vpn spoofing apps, creating new accounts, and messing with phone or console settings. I know they don't pirate cause I searched Final Fantasy Dimensions japanese name in kanji as a test, and we all know that isn't a free game. Never showed up on the apps search bar, and the app had no idea what I was looking for despite a copy/paste of the name. Only free games are shown on it

    An additional note since this occurred today. The game is tending to be a pain in the rear about loading up. It only gets so far, then you'll notice the loading icon freeze up and the game exit out to the ouya make menu. Clearing cache for the game might be advisable as I checked that and it had a little over 5MB worth of cache data. A reboot of your ouya may also be needed. Also looking at the games data in ouyas advanced settings shows that the game is 287MB as opposed to the 208MB I mentioned in the first post. On my phone it was 208MB, and assumed it wouldn't be much different but apparently it is. Must be device differences.

    Edit: After quickly doing that it seems that a cache clear and reboot got it over the hump, that was stopping it. For some reason it's got a download progress bar, which I assume was stopping the game from loading since it wasn't there before. Might even have to check qooapp for a update to the game.

    Edit again: Simplest and stupidest reason caused that. My internet connection skitz on me a lil at some point. Problem resolved.

    Last Edit: This an edited post....not merged. Huge difference between the two since one suggests a double post was merged to the previous post before it. I clearly know how to edit my posts, which are singular.
    Last edited by nightwishfan1; 06-21-2016 at 11:40 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •