Advertise Here
Results 1 to 3 of 3

Thread: Root?

  1. #1


    I had to get a new Ouya. The original one I bought died on me. Is there still a way to root the system since the one click root application doesn't work anymore? Thanks!

  2. #2

    I'd probably say do the usual. Which it seems like the Cut Corners way of doing it is to use one of the Chinese Root Programs like Kingroot or something
    I did and for the longest time I left it and it worked great. I also wanted to remove that Chinese SU root app for the longest time as well. I think it was called KingUser or something. One day
    I finally gave in and got brave and used to remove the Chinese
    KingUser program. I also had a usb keyboard hooked up to the Ouya as well and I downloaded Terminal from GP(Google Play store, because I was rooted but I'm wondering if you could push something like a terminal android program ala terminal.apk to your Ouya without being rooted? like how you would from the Make category I believe? Once I had the terminal installed I just followed all the directions and it worked. I also somehow installed the Xpose framework and all that and cant remember exactly how I did that but it all seemed to have worked fine. That Xposed might have been from a root my ouya pack. Not even sure how or why I did that but the original tutorial I watched on youtube also had instructed on how to install that Xposed as well. The collection might have even been called Mod My Ouya or something. I would doubt you would even need that whole pack and can probably root with the Chinese root app and then follow the instructions from the url above to remove the Chinese App and Replace with superSU root app. I think the purpose of the xposed installer was just basically to be used to enable some controller mods are something to get the Moga/Pivot controllers to work correctly. Then again if I'm not mistaken I think I do remember the mod having something in regards to enabling superSU recovery and enabling Google Play store as well. Not sure though but somehow I ended up getting to where I wanted with the full GP and Amazon stores working fine. Didn't mess up the discovery store or anything either.

  3. #3
    OUYA Developer Eldon.McGuinness's Avatar
    Join Date
    Oct 2013

    There are lots of ways to root the OUYA, you can use the script that I put together, ReRoot. It is not for the feint of heart and does require adb, but it does offer more than just root. The other option is to use one of the closed source projects such as kingroot, but you never know what else those things are doing.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts