Close
Advertise Here
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    OUYA Developer Kaimega's Avatar
    Join Date
    Jun 2013
    Location
    Montreal, Canada
    Posts
    4,595


    Quote Originally Posted by underground View Post
    What engine are you compiling with? GameMaker?


    Enviado desde mi iPad utilizando Tapatalk
    He is using Game Maker
    Racin-Games, creator of Sirenium ~ Forever After ~ .. come check us out here! http://www.racin-games.com
    Forum Page: http://ouyaforum.com/showthread.php?...-Forever-After
    If you want your game/app reviewed, let me know! I'll ReviOUYA. Will also do previews and such as well. http://reviouya.wordpress.com/
    Play like me! http://ouyaforum.com/showthread.php?...imega&p=119559

  2. #12


    Quote Originally Posted by Steven W. Hunt View Post
    So I do a bit o' digging, and it looks like maybe I need to kick in the OUYA Everywhere extensions? Thought I did that. So I do it. And when I try to build the APK....
    Code:
    Validation failed, exiting
     FAILED
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    Execution failed for task ':com.ccsh.chomperman:processArmeabi-v7aReleaseManifest'.
    > Manifest merger failed with multiple errors, see logs
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    BUILD FAILED
    This error appears when use Ouya anywhere extension on GM Studio newer releases ( > 1.4.1675).
    You have two choices:

    - The first and the esay way, is to compile your project with older releases of GM:S below 1.4.1675 (also this way is that Tim Graupman suggest to use).

    - Second is if you want/need to use newer releases, follow these easy steps: Open the properties window of OuyaSDK.ext extension inside GM:S, select the Android tab and remove all the code that appears on the "Inject to AndroidManifest.xml" and "Inject to Gradle dependencies" boxes. Click OK and try to compile your project now. This works fine for me, but Tim told me that this method may not work with the IAP functions, but I made a test app and worked fine, IAP functions included.

    Hope these help you.

    Regards,
    Fran
    Last edited by underground; 06-21-2016 at 09:26 PM.

  3. #13
    OUYA Developer Steven W. Hunt's Avatar
    Join Date
    Sep 2013
    Location
    Moesko Island, WA
    Posts
    651


    Quote Originally Posted by underground View Post
    This error appears when use Ouya anywhere extension on GM Studio newer releases ( > 1.4.1675).
    You have two choices:

    - The first and the esay way, is to compile your project with older releases of GM:S below 1.4.1675 (also this way is that Tim Graupman suggest to use).

    - Second is if you want/need to use newer releases, follow these easy steps: Open the properties window of OuyaSDK.ext extension inside GM:S, select the Android tab and remove all the code that appears on the "Inject to AndroidManifest.xml" and "Inject to Gradle dependencies" boxes. Click OK and try to compile your project now. This works fine for me, but Tim told me that this method may not work with the IAP functions, but I made a test app and worked fine, IAP functions included.

    Hope these help you.

    Regards,
    Fran
    Thanks. I tried the second option and now I'm getting

    Code:
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    Execution failed for task ':com.ccsh.chomperman:lint'.
    > Lint found errors in the project; aborting build.
    
    Fix the issues identified by lint, or add the following to your build script to proceed with errors:
    ...
    android {
        lintOptions {
            abortOnError false
        }
    }
    ...
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    BUILD FAILED
    Last edited by Steven W. Hunt; 06-22-2016 at 06:00 AM.
    http://www.ccshgames.com - Updated 1/10/2016
    PC & Mac games - Updated more frequently
    OUYA games I've had a hand in: Slashers: The Power Battle (voice actor), Battle High 2 (casting/marketing director, voice actor), Astra Etherium (voice actor)
    OUYA games published: Shady's Poopong: 22nd Anniversary Edition, Chomperman

  4. #14


    Have you tried to clear the assets cache before compiling?

  5. #15


    Also you have to use these settings on the Android Tab on GGS:

    Build tools: 23.0.1
    Support Lib: 23.1.1
    Target SDK: 23
    Min SDK: 16
    Compile SDK: 23

    You´ll get "lint" errors if you don´t have the correct SDK versions selected.

  6. #16
    OUYA Developer Steven W. Hunt's Avatar
    Join Date
    Sep 2013
    Location
    Moesko Island, WA
    Posts
    651


    My target SDK and Min SDK are 16 and 9. I'll look into that and give it a go. Thanks!

    EDIT: Ahhhh I still get the Lint errors and I don't understand this report it's so long.

    ../intermediates/classes/release/tv/ouya/sdk/DebugInput.class: Call requires API level 12 (current min is 9): android.view.MotionEvent#getAxisValue
    ../intermediates/classes/release/tv/ouya/sdk/OuyaInputView%24ViewRemappedEventDispatcher.class: Call requires API level 12 (current min is 9): android.view.View#onGenericMotionEvent
    ../intermediates/classes/release/tv/ouya/sdk/OuyaInputView.class: Call requires API level 12 (current min is 9): android.view.MotionEvent#getAxisValue
    ../../src/main/java/com/ccsh/chomperman/OuyaSDK.java:623: Call requires API level 12 (current min is 9): android.view.View#dispatchGenericMotionEvent
    Last edited by Steven W. Hunt; 06-27-2016 at 02:19 AM.
    http://www.ccshgames.com - Updated 1/10/2016
    PC & Mac games - Updated more frequently
    OUYA games I've had a hand in: Slashers: The Power Battle (voice actor), Battle High 2 (casting/marketing director, voice actor), Astra Etherium (voice actor)
    OUYA games published: Shady's Poopong: 22nd Anniversary Edition, Chomperman

  7. #17
    OUYAForum Fan xAD's Avatar
    Join Date
    Jul 2013
    Location
    Elsewhere
    Posts
    529


    1 members found this post helpful.
    I have no idea what any of that means...but it looks like it would all clear up if you changed your MinSDK to 12
    OUYA console to become doorstop when store server shuts down. But since it seems to be safe so far, we just need a place to collect new (and updated?) OUYA titles.
    Have you made your game sideload-able for OUYA hardware? Put it on http://itch.io, then let me know and i'll add it to a collection we can all link to.

  8. #18


    Make sure that you have all these apis installed in android sdk manager. Check again your GGS settings, clear the assets cache and save your GM project.
    Then try to compile again.

    Enviado desde mi LG-D620 mediante Tapatalk

  9. #19


    Well, now that I have a ForgeTV, I´m making some testings with GM:S.
    Builds compiled with releases over GM:S 1.4.1675 and using the OUYA Anywhere extension, works fine on OUYA but don´t work on ForgeTV (even with the mods that I described in this post).
    So to make games for the ForgeTV, is mandatory to use releases below 1.4.1675 (those that don´t use gradle compiling).

    I hope that Tim could make an update of the extension soon.

  10. #20
    OUYA Developer Steven W. Hunt's Avatar
    Join Date
    Sep 2013
    Location
    Moesko Island, WA
    Posts
    651


    Quote Originally Posted by underground View Post
    Well, now that I have a ForgeTV, I´m making some testings with GM:S.
    Builds compiled with releases over GM:S 1.4.1675 and using the OUYA Anywhere extension, works fine on OUYA but don´t work on ForgeTV (even with the mods that I described in this post).
    So to make games for the ForgeTV, is mandatory to use releases below 1.4.1675 (those that don´t use gradle compiling).

    I hope that Tim could make an update of the extension soon.
    Hey sorry I hadn't been in the topic in a while. hadn't gotten around to trying any of the stuff described above... been a bit busy the last month.
    It's pretty dumb that I'd have to get an older version of GMS to be able to do what I want with it. I wouldn't even know how to do that... especially without messing up my current version.
    http://www.ccshgames.com - Updated 1/10/2016
    PC & Mac games - Updated more frequently
    OUYA games I've had a hand in: Slashers: The Power Battle (voice actor), Battle High 2 (casting/marketing director, voice actor), Astra Etherium (voice actor)
    OUYA games published: Shady's Poopong: 22nd Anniversary Edition, Chomperman

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •