Hello , just wanted to add that I'm able to run Kodi v16.1 on my Cyanongen Mod v11 .... will see how long before Kodi v16 is no longer supported.:fatigue: