PDA

View Full Version : Has anyone tried flashing anything unofficial through recovery yet?



sonofskywalker3
05-21-2013, 03:58 PM
I'm planning on putting together a recovery flashable package to include some working streaming/media apps, the chrome browser, a 3rd party launcher, and possibly some other stuff, but I'm wondering if a modified OTA is able to be flashed through stock recovery or not. Has anyone tried it yet? If not I'll give it a shot tonight and post the results.

T3KN0GH057
05-22-2013, 06:12 AM
I'm really interested in the results of this. Gonna keep a solid watch on this thread

DrunkPunk
05-22-2013, 06:46 AM
For sure. It would be great if it was that easy. Please let us know how it went!

derty
05-22-2013, 02:17 PM
Not sure what this all means but I like getting hyped about new things happening to this system :)

sonofskywalker3
05-23-2013, 09:30 PM
I did try simply adding an additional app to the ota download and flashing it in stock recovery, but it didnt work. So since I am not seeing anyone else working on it, i've decided to try and port Clockworkmod Recovery to the Ouya myself. I'll update if I make any progress.

professorpoptart
05-24-2013, 01:07 AM
I did try simply adding an additional app to the ota download and flashing it in stock recovery, but it didnt work. So since I am not seeing anyone else working on it, i've decided to try and port Clockworkmod Recovery to the Ouya myself. I'll update if I make any progress.

how did you flash in stock recovery? I assume adb reboot recovery... I have no video output and I'm trying to get into recovery so I can try "recovery --update_package=ota.zip". but it doesnt look like im getting into recovery, as i get recovery not found.

sonofskywalker3
05-24-2013, 03:24 AM
how did you flash in stock recovery? I assume adb reboot recovery... I have no video output and I'm trying to get into recovery so I can try "recovery --update_package=ota.zip". but it doesnt look like im getting into recovery, as i get recovery not found.

I replied to your post on XDA with detailed instructions professor, good luck. On the topic of flashing here's a CWM update:

I have compiled a version of CWM recovery that theoretically should work, but I'm unable to flash it. I have installed flash_image onto the ouya and it works fine, but i normally would have used "flash_image recovery recovery.img" however there is no "recovery" partition on the ouya. This is what I get:

./flash_image recovery recovery.img
error scanning partitions: No such file or directory

Mount reveals the following info:

mount
rootfs / rootfs ro,relatime 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
/dev/block/platform/sdhci-tegra.3/by-name/APP /system ext4 ro,relatime,user_xatt
r,acl,barrier=1,data=ordered 0 0
/dev/block/platform/sdhci-tegra.3/by-name/CAC /cache ext4 rw,nosuid,nodev,noatim
e,errors=panic,user_xattr,acl,barrier=1,journal_as ync_commit,nodelalloc,data=wri
teback 0 0
/dev/block/platform/sdhci-tegra.3/by-name/UDA /data ext4 rw,nosuid,nodev,noatime
,errors=panic,user_xattr,acl,barrier=1,journal_asy nc_commit,nodelalloc,data=writ
eback 0 0
/dev/fuse /storage/sdcard0 fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1
023,default_permissions,allow_other 0 0

This is the script from the OTA update:
#!/system/bin/sh
if ! applypatch -c EMMC:/dev/block/platform/sdhci-tegra.3/by-name/SOS:5906432:f80238c4f4a53888b547e4463fb4751343f234 12; then
log -t recovery "Installing new recovery image"
applypatch EMMC:/dev/block/platform/sdhci-tegra.3/by-name/LNX:5277696:5d7013bf98f76199ea5b7d7d8baeb07fa3ad26 ff EMMC:/dev/block/platform/sdhci-tegra.3/by-name/SOS f80238c4f4a53888b547e4463fb4751343f23412 5906432 5d7013bf98f76199ea5b7d7d8baeb07fa3ad26ff:/system/recovery-from-boot.p
else
log -t recovery "Recovery image already installed"
fi

but I can't make any sense of it. If anyone can help out i'd much appreciate it...

DrunkPunk
05-24-2013, 07:36 AM
Here's a link to the dev boards. Somebody figured out a way to force the Ouya into recovery. Not sure if this will help or not but any information might be useful!
http://forums.ouya.tv/discussion/1380/recovery-mode

Magnesus
05-24-2013, 07:50 AM
Maybe recovery isn't mounted? By name it should be SOS though.

sonofskywalker3
05-24-2013, 11:30 AM
Here's a link to the dev boards. Somebody figured out a way to force the Ouya into recovery. Not sure if this will help or not but any information might be useful!
http://forums.ouya.tv/discussion/1380/recovery-mode Thank you, but i can boot into stock recovery no problem, it's just that the new recovery is a .img file and not a flashable zip.